Saturday, November 27, 2021

#1 2021-11-11 02:49:47 pm

redsweater
Member
From:: Arlington, MA
Registered: 2003-04-12
Posts: 60
Website

FastScripts 3 is now available

Hi folks! I know there are some long-time FastScripts fans in the forum so I wanted to make sure you are aware of a major new upgrade to FastScripts which supports new features including parallel execution of scripts, searching the script menu, showing script progress, and more. You can read more about the update here:

https://redsweater.com/blog/3784/fastscripts-3

Thanks!
Daniel

Offline

 

#2 2021-11-11 04:11:01 pm

Shane Stanley
Member
From:: Australia
Registered: 2002-12-07
Posts: 6729

Re: FastScripts 3 is now available

Congratulations! Nice upgrade smile


Shane Stanley <sstanley@myriad-com.com.au>
www.macosxautomation.com/applescript/apps/
latenightsw.com

Offline

 

#3 2021-11-11 04:14:23 pm

redsweater
Member
From:: Arlington, MA
Registered: 2003-04-12
Posts: 60
Website

Re: FastScripts 3 is now available

Thanks, Shane!!

Offline

 

#4 2021-11-12 12:29:39 pm

t.spoon
Member
From:: BFE, Massachusetts
Registered: 2013-01-13
Posts: 518

Re: FastScripts 3 is now available

This looks fantastic. The parallel processing with progress indicators and script stop buttons will be really handy. We'll try it out and I hope we'll upgrade all users soon.

Thanks,

Tom.


Ditched the Hackintosh.
Intel Mac Mini i7 and M1 Mac Mini on a KVM.

Offline

 

#5 2021-11-16 09:55:14 am

t.spoon
Member
From:: BFE, Massachusetts
Registered: 2013-01-13
Posts: 518

Re: FastScripts 3 is now available

Ah, I didn't see it requires 10.15 or newer... we're mostly on Mojave, so we'll need to get users past that first.

Is there still a URL to download the last version of Fastscripts 2.x? We're going to to need to keep installing that until we're past Mojave.

Thanks.


Ditched the Hackintosh.
Intel Mac Mini i7 and M1 Mac Mini on a KVM.

Offline

 

#6 2021-11-16 09:58:30 am

redsweater
Member
From:: Arlington, MA
Registered: 2003-04-12
Posts: 60
Website

Re: FastScripts 3 is now available

FastScripts officially requires 10.15 but I left 10.14 support enabled for anybody who wants to give it a try. At some point during 3.0 development I ran into an issue that made me think I didn't want to fully support 10.14, but unfortunately I can't remember it right now. Might have been some visual glitch that you could live with if it doesn't bother you.

You can download the latest FastScripts 2.x here:

https://redsweater.com//fastscripts/Fas … s2.8.3.zip

Daniel

Offline

 

#7 2021-11-16 07:57:34 pm

t.spoon
Member
From:: BFE, Massachusetts
Registered: 2013-01-13
Posts: 518

Re: FastScripts 3 is now available

Great, thanks Daniel. Appreciate the link.

Fastscripts is mission-critical for us, so I think we'll wait to go to 3 until we're past Mojave. We hope to be there soon.


Ditched the Hackintosh.
Intel Mac Mini i7 and M1 Mac Mini on a KVM.

Offline

 

Board footer

Powered by FluxBB

RSS (new topics) RSS (active topics)