Saturday, October 1, 2022

#1 2021-01-26 10:33:36 am

Registered: 2019-12-05
Posts: 31

Move Finder Items does not "Move"

Hi all, I have an Automator workflow that creates a job folder structure from a supplied folder with one or two files in the original folder. Among other actions the workflow creates a sub folder that moves the contents of the original dropped folder into it, using the Move Finder Items action.
However this does not "move" the item(s) but copies it leaving the original folders contents present, which I do not want.

I've tried many variations on this and it won't "move" the files. I've even tried using a Move Finder Items to Trash command for the originals once copied but without any success.

Is this  a bug that it won't move items or am I doing something wrong?




#2 2021-05-06 09:48:39 am

From:: Greece
Registered: 2019-03-03
Posts: 2524

Re: Move Finder Items does not "Move"

Use Run AppleScript action instead. The script should include move command of Finder.

1) Workflow receives current files and folder
2) Run AppleScript (Finder items move script)

Model: MacBook Pro
OS X: Catalina 10.15.7
Web Browser: Safari 14.1
Ram: 4 GB



Board footer

Powered by FluxBB

RSS (new topics) RSS (active topics)