Wednesday, June 28, 2017

#1 2017-01-21 07:33:29 am

robdut
Member
Registered: 2009-09-02
Posts: 293

Suddenly AppleScript files won't compile

Hi All,

A couple days ago I tried building my main app (for the millionth time) and got error in the delegate

Applescript:


backupCAppDelegate.applescript:122: error: Expected variable name, class name or property but found command name. (-2741)

the offending line (obviously isn't the issue)

Applescript:


property backup : missing value

It's a big script, close to 2000 lines, but has compiled fine for years. There are several scripts and one a bit bigger. It also compiles fine on my iMac but not on the MacBook pro. I reinstalled Xcode 8.2 twice, even clean installed OS Sierra and then reinstalled Xcode again. Still get same error. Code is fine as it runs on other machine fine.

Am completely stumped as to why suddenly it should start doing this. Nothing has changed that I can think of but I was doing a lot of testing, intensive cpu stuff, and noticed a while later the problem.

Any ideas?

Thanks, Rob

Last edited by robdut (2017-01-21 07:35:47 am)

Offline

 

#2 2017-01-21 07:36:50 am

StefanK
Member
From: St. Gallen, Switzerland
Registered: 2006-10-21
Posts: 11451
Website

Re: Suddenly AppleScript files won't compile

Try to clean the project (⇧⌘K) and / or the build folder (⌥⇧⌘K)


regards

Stefan

Offline

 

#3 2017-01-21 07:53:18 am

robdut
Member
Registered: 2009-09-02
Posts: 293

Re: Suddenly AppleScript files won't compile

Yes I Cleaned a dozen times and build folder, removed whole derived data folder, everything I could find to start fresh.
I commented out the offending line and it just picks another line to "pick" on!  I managed to get it past the delegate script but now am seeing this in the main controller script. Oddly the script is called "script backup" and "backup" was the outlet for it in the delegate script that first got hit...

Applescript:

backup.applescript:2917: error: Expected end of line, etc. but found “script”. (-2741)
Command /usr/bin/osacompile failed with exit code 1

Offline

 

Board footer

Powered by FluxBB

[ Generated in 0.036 seconds, 10 queries executed ]

RSS (new topics) RSS (active topics)